re = /.+([chds]).+\1.+\1.+\1.+\1/m
str = '10hJh7hAh2h
10cJcQcKcAc
10cJcQcKhAh // No Match
2d3d4d5d6d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end