using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\pL)[\pL\pN]+(?:[ -]+[\pL\pN]+)*$";
string input = @"Street
Some-Street
Street
Street
Street-
-Street
1 st Street
Street 5
111
A
9
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}