$re = '/^(?=.*\pL)[\pL\pN]+(?:[ -]+[\pL\pN]+)*$/m';
$str = 'Street
Some-Street
Street
Street
Street-
-Street
1 st Street
Street 5
111
A
9
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);