import re
regex = re.compile(r"^(?=.*\pL)[\pL\pN]+(?:[ -]+[\pL\pN]+)*$", flags=re.MULTILINE)
test_str = ("Street\n"
"Some-Street\n"
"Street \n"
" Street\n"
"Street-\n"
"-Street\n"
"1 st Street\n"
"Street 5\n"
"111\n"
"A\n"
"9\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")