re = /^(?=.*\pL)[\pL\pN]+(?:[ -]+[\pL\pN]+)*$/m
str = 'Street
Some-Street
Street
Street
Street-
-Street
1 st Street
Street 5
111
A
9
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end