const regex = /^(?=.*\pL)[\pL\pN]+(?:[ -]+[\pL\pN]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\pL)[\\pL\\pN]+(?:[ -]+[\\pL\\pN]+)*$', 'gm')
const str = `Street
Some-Street
Street
Street
Street-
-Street
1 st Street
Street 5
111
A
9
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}