# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/%(\w)/\1/g;t' <<< "%252525253E%252553Csvg%25252525252525252Fonload%252525252525252525252525252525252525252525252525252525253Dalert(document.domain)%252525252"