use strict;
my $str = '%252525253E%252553Csvg%25252525252525252Fonload%252525252525252525252525252525252525252525252525252525253Dalert(document.domain)%252525252';
my $regex = qr`%(\w)`p;
my $subst = '\\1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";