using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%(\w)";
string substitution = @"\1";
string input = @"%252525253E%252553Csvg%25252525252525252Fonload%252525252525252525252525252525252525252525252525252525253Dalert(document.domain)%252525252";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}