re = /%(\w)/
str = '%252525253E%252553Csvg%25252525252525252Fonload%252525252525252525252525252525252525252525252525252525253Dalert(document.domain)%252525252'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result