const regex = new RegExp('^((http|https):\\/\\/)?([\\w\\.]*(?:(?:\\/[\\.\\w]+)+)?)', 'gm')
const str = `https://stackoverflow.com/questions/3809401/url?test=1
http://stackoverflow.com/questions/3809401/url/?test=1
https://stackoverflow.com/questions/3809401url
http://stackoverflow.com?test=1
http://stackoverflow.com/
http://stackoverflow.com/test/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}