// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((http|https):\/\/)?([\w\.]*(?:(?:\/[\.\w]+)+)?)").unwrap();
let string = "https://stackoverflow.com/questions/3809401/url?test=1
http://stackoverflow.com/questions/3809401/url/?test=1
https://stackoverflow.com/questions/3809401url
http://stackoverflow.com?test=1
http://stackoverflow.com/
http://stackoverflow.com/test/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}