re = /^((http|https):\/\/)?([\w\.]*(?:(?:\/[\.\w]+)+)?)/m
str = 'https://stackoverflow.com/questions/3809401/url?test=1
http://stackoverflow.com/questions/3809401/url/?test=1
https://stackoverflow.com/questions/3809401url
http://stackoverflow.com?test=1
http://stackoverflow.com/
http://stackoverflow.com/test/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end