import Foundation
let pattern = #"^((http|https):\/\/)?([\w\.]*(?:(?:\/[\.\w]+)+)?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://stackoverflow.com/questions/3809401/url?test=1
http://stackoverflow.com/questions/3809401/url/?test=1
https://stackoverflow.com/questions/3809401url
http://stackoverflow.com?test=1
http://stackoverflow.com/
http://stackoverflow.com/test/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)