$re = '/^((http|https):\/\/)?([\w\.]*(?:(?:\/[\.\w]+)+)?)/m';
$str = 'https://stackoverflow.com/questions/3809401/url?test=1
http://stackoverflow.com/questions/3809401/url/?test=1
https://stackoverflow.com/questions/3809401url
http://stackoverflow.com?test=1
http://stackoverflow.com/
http://stackoverflow.com/test/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);