using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^localhost:8080(?!\/api)(?:\/\w+)*$";
string input = @"localhost:8080
localhost:8080/settings
localhost:8080/settings/users
localhost:8080/settings/users/roles
localhost:8080/settings/users/roles/admin
localhost:8080/style.css
localhost:8080/manifest.json
localhost:8080/api
localhost:8080/api/users
localhost:8080/api/users/abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}