re = /^localhost:8080(?!\/api)(?:\/\w+)*$/m
str = 'localhost:8080
localhost:8080/settings
localhost:8080/settings/users
localhost:8080/settings/users/roles
localhost:8080/settings/users/roles/admin
localhost:8080/style.css
localhost:8080/manifest.json
localhost:8080/api
localhost:8080/api/users
localhost:8080/api/users/abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end