import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^localhost:8080(?!\\/api)(?:\\/\\w+)*$";
final String string = "localhost:8080\n"
+ "localhost:8080/settings\n"
+ "localhost:8080/settings/users\n"
+ "localhost:8080/settings/users/roles\n"
+ "localhost:8080/settings/users/roles/admin\n\n"
+ "localhost:8080/style.css\n"
+ "localhost:8080/manifest.json\n"
+ "localhost:8080/api\n"
+ "localhost:8080/api/users\n"
+ "localhost:8080/api/users/abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}