const regex = /^localhost:8080(?!\/api)(?:\/\w+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^localhost:8080(?!\\\/api)(?:\\\/\\w+)*$', 'gm')
const str = `localhost:8080
localhost:8080/settings
localhost:8080/settings/users
localhost:8080/settings/users/roles
localhost:8080/settings/users/roles/admin
localhost:8080/style.css
localhost:8080/manifest.json
localhost:8080/api
localhost:8080/api/users
localhost:8080/api/users/abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}