using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(R)[^|]+(\|)";
string substitution = @"$1$2";
string input = @"RDA
3|4|";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}