import re
regex = re.compile(r"(R)[^|]+(\|)", flags=re.MULTILINE)
test_str = ("RDA\n"
"3|4|")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)