use strict;
my $str = 'RDA
3|4|';
my $regex = qr/(R)[^|]+(\|)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";