const regex = /(R)[^|]+(\|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(R)[^|]+(\\|)', 'gm')
const str = `RDA
3|4|`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);