# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|,).{4}/$1/gm;t' <<< "/en/house/125,/en/house/145,/en/house/06
/en/house/45,/fr/house/22,/fr/house/34"