// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^|,).{4}").unwrap();
let string = "/en/house/125,/en/house/145,/en/house/06
/en/house/45,/fr/house/22,/fr/house/34";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}