using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|,).{4}";
string substitution = @"$1";
string input = @"/en/house/125,/en/house/145,/en/house/06
/en/house/45,/fr/house/22,/fr/house/34";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}