re = /(^|,).{4}/m
str = '/en/house/125,/en/house/145,/en/house/06
/en/house/45,/fr/house/22,/fr/house/34'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result