use strict;
my $str = '/en/house/125,/en/house/145,/en/house/06
/en/house/45,/fr/house/22,/fr/house/34';
my $regex = qr/(^|,).{4}/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";