#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<([\w\d]+)\b([^id\>]+)(id="email-notes")([^>]+)?>(\s+)?(?=[\d\w]+)[^\<\>]+<\/\1>"
Local $sString = "<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>" & @CRLF & _
"" & @CRLF & _
"<p class="comment-notes"><span id="email-notes">Your email address will not be published. Required fields are marked <span class="required">*</span></p>" & @CRLF & _
"" & @CRLF & _
"<p class="comment-notes"><span id="email-notes"></span> Required fields are marked <span class="required">*</span></p>" & @CRLF & _
"" & @CRLF & _
"<p class="comment-notes"><span id="email-notes"> </span> Required fields are marked <span class="required">*</span></p>" & @CRLF & _
"" & @CRLF & _
"<p class="comment-notes"><span id="email-notes"> Cat </span> Required fields are marked <span class="required">*</span></p>" & @CRLF & _
"" & @CRLF & _
"<p class="comment-notes"><span id="email-notes" id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>" & @CRLF & _
"" & @CRLF & _
"<p class="comment-notes"><span id="email-notes" data-id="break">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>" & @CRLF & _
"" & @CRLF & _
"<p class="comment-notes"><span class="hello" id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>" & @CRLF & _
"" & @CRLF & _
"<p class="comment-notes"><span class="hello" id="email-notes" style="background: #ccc;">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>" & @CRLF & _
"" & @CRLF & _
"<p class="comment-notes"><span class="hello" id="email-notes" style="background: #ccc;" data-json='{"name": "Tung"}'>Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")