import re
regex = re.compile(r"<([\w\d]+)\b([^id\>]+)(id=\"email-notes\")([^>]+)?>(\s+)?(?=[\d\w]+)[^\<\>]+<\/\1>", flags=re.MULTILINE)
test_str = ("<p class=\"comment-notes\"><span id=\"email-notes\">Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
"<p class=\"comment-notes\"><span id=\"email-notes\">Your email address will not be published. Required fields are marked <span class=\"required\">*</span></p>\n\n"
"<p class=\"comment-notes\"><span id=\"email-notes\"></span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
"<p class=\"comment-notes\"><span id=\"email-notes\"> </span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
"<p class=\"comment-notes\"><span id=\"email-notes\"> Cat </span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
"<p class=\"comment-notes\"><span id=\"email-notes\" id=\"email-notes\">Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
"<p class=\"comment-notes\"><span id=\"email-notes\" data-id=\"break\">Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
"<p class=\"comment-notes\"><span class=\"hello\" id=\"email-notes\">Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
"<p class=\"comment-notes\"><span class=\"hello\" id=\"email-notes\" style=\"background: #ccc;\">Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
"<p class=\"comment-notes\"><span class=\"hello\" id=\"email-notes\" style=\"background: #ccc;\" data-json='{\"name\": \"Tung\"}'>Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")