import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([\\w\\d]+)\\b([^id\\>]+)(id=\"email-notes\")([^>]+)?>(\\s+)?(?=[\\d\\w]+)[^\\<\\>]+<\\/\\1>";
final String string = "<p class=\"comment-notes\"><span id=\"email-notes\">Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
+ "<p class=\"comment-notes\"><span id=\"email-notes\">Your email address will not be published. Required fields are marked <span class=\"required\">*</span></p>\n\n"
+ "<p class=\"comment-notes\"><span id=\"email-notes\"></span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
+ "<p class=\"comment-notes\"><span id=\"email-notes\"> </span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
+ "<p class=\"comment-notes\"><span id=\"email-notes\"> Cat </span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
+ "<p class=\"comment-notes\"><span id=\"email-notes\" id=\"email-notes\">Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
+ "<p class=\"comment-notes\"><span id=\"email-notes\" data-id=\"break\">Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
+ "<p class=\"comment-notes\"><span class=\"hello\" id=\"email-notes\">Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
+ "<p class=\"comment-notes\"><span class=\"hello\" id=\"email-notes\" style=\"background: #ccc;\">Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>\n\n"
+ "<p class=\"comment-notes\"><span class=\"hello\" id=\"email-notes\" style=\"background: #ccc;\" data-json='{\"name\": \"Tung\"}'>Your email address will not be published.</span> Required fields are marked <span class=\"required\">*</span></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}