import Foundation
let pattern = #"<([\w\d]+)\b([^id\>]+)(id="email-notes")([^>]+)?>(\s+)?(?=[\d\w]+)[^\<\>]+<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes">Your email address will not be published. Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes"></span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes"> </span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes"> Cat </span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes" id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes" data-id="break">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span class="hello" id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span class="hello" id="email-notes" style="background: #ccc;">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span class="hello" id="email-notes" style="background: #ccc;" data-json='{"name": "Tung"}'>Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)