$re = '/<([\w\d]+)\b([^id\>]+)(id="email-notes")([^>]+)?>(\s+)?(?=[\d\w]+)[^\<\>]+<\/\1>/m';
$str = '<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes">Your email address will not be published. Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes"></span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes"> </span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes"> Cat </span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes" id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span id="email-notes" data-id="break">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span class="hello" id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span class="hello" id="email-notes" style="background: #ccc;">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-notes"><span class="hello" id="email-notes" style="background: #ccc;" data-json=\'{"name": "Tung"}\'>Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);