#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^1\.(?:.*\n)+Related Entities"
Local $sString = "some text" & @CRLF & _
"1. random string" & @CRLF & _
"...random lines of strings" & @CRLF & _
"...random lines of strings" & @CRLF & _
"Related Entities" & @CRLF & _
"some other text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")