package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1\.(?:.*\n)+Related Entities`)
var str = `some text
1. random string
...random lines of strings
...random lines of strings
Related Entities
some other text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}