re = /^1\.(?:.*\n)+Related Entities/m
str = 'some text
1. random string
...random lines of strings
...random lines of strings
Related Entities
some other text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end