$re = '/^1\.(?:.*\n)+Related Entities/m';
$str = 'some text
1. random string
...random lines of strings
...random lines of strings
Related Entities
some other text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);