// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^1\.(?:.*\n)+Related Entities").unwrap();
let string = "some text
1. random string
...random lines of strings
...random lines of strings
Related Entities
some other text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}