#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d{1,2}[A-Z]{3}(?:\d{2}|\d{4})\b"
Local $sString = "/AB/25MAR1992/" & @CRLF & _
"/AB/25MAR92/" & @CRLF & _
"/AB/2MAR92/" & @CRLF & _
"/AB/02MAR92/" & @CRLF & _
"/AB/02MAR992/" & @CRLF & _
"/AB/02MAR992/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")