import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{1,2}[A-Z]{3}(?:\\d{2}|\\d{4})\\b";
final String string = "/AB/25MAR1992/\n"
+ "/AB/25MAR92/\n"
+ "/AB/2MAR92/\n"
+ "/AB/02MAR92/\n"
+ "/AB/02MAR992/\n"
+ "/AB/02MAR992/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}