re = /\b\d{1,2}[A-Z]{3}(?:\d{2}|\d{4})\b/m
str = '/AB/25MAR1992/
/AB/25MAR92/
/AB/2MAR92/
/AB/02MAR92/
/AB/02MAR992/
/AB/02MAR992/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end