package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{1,2}[A-Z]{3}(?:\d{2}|\d{4})\b`)
var str = `/AB/25MAR1992/
/AB/25MAR92/
/AB/2MAR92/
/AB/02MAR92/
/AB/02MAR992/
/AB/02MAR992/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}