#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^[^\S\r\n]*(text|choice)[^\S\r\n]*""
Local $sString = "text "","text1"" & @CRLF & _
"waitinput" & @CRLF & _
"text "","text2"" & @CRLF & _
"waitinput" & @CRLF & _
"text "{user}","text3"" & @CRLF & _
"waittext" & @CRLF & _
"" & @CRLF & _
"choice "option1","option2"" & @CRLF & _
"" & @CRLF & _
" text "","text4"" & @CRLF & _
" waitinput" & @CRLF & _
" text "{user}","text5"" & @CRLF & _
" waitinput" & @CRLF & _
"" & @CRLF & _
" text "char","text6"" & @CRLF & _
" waitinput"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")