const regex = /(?m)^[^\S\r\n]*(text|choice)[^\S\r\n]*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^[^\\S\\r\\n]*(text|choice)[^\\S\\r\\n]*"', 'gm')
const str = `text "","text1"
waitinput
text "","text2"
waitinput
text "{user}","text3"
waittext
choice "option1","option2"
text "","text4"
waitinput
text "{user}","text5"
waitinput
text "char","text6"
waitinput`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}