// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?m)^[^\S\r\n]*(text|choice)[^\S\r\n]*""#).unwrap();
let string = "text \"\",\"text1\"
waitinput
text \"\",\"text2\"
waitinput
text \"{user}\",\"text3\"
waittext
choice \"option1\",\"option2\"
text \"\",\"text4\"
waitinput
text \"{user}\",\"text5\"
waitinput
text \"char\",\"text6\"
waitinput";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}