re = /(?m)^[^\S\r\n]*(text|choice)[^\S\r\n]*"/m
str = 'text "","text1"
waitinput
text "","text2"
waitinput
text "{user}","text3"
waittext
choice "option1","option2"
text "","text4"
waitinput
text "{user}","text5"
waitinput
text "char","text6"
waitinput'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end