using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^[^\S\r\n]*(text|choice)[^\S\r\n]*""";
string input = @"text "",""text1""
waitinput
text "",""text2""
waitinput
text ""{user}"",""text3""
waittext
choice ""option1"",""option2""
text "",""text4""
waitinput
text ""{user}"",""text5""
waitinput
text ""char"",""text6""
waitinput";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}