#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(Leader|Head\\Organiser|Head|Head\\Secretary|Captain|Vice Captain)[ \t:-]+(.*?)[ \t]*[;#]+"
Local $sString = "Leader : Tim Lee ; 34567" & @CRLF & _
"Head\Organiser: Sam Mathews; 11:53 am" & @CRLF & _
"Head: Alica Mills; 45612" & @CRLF & _
"Head\Secretary: Maya Hill; #53190" & @CRLF & _
"Captain- Jocey David # 45123" & @CRLF & _
"Vice Captain:- Jacob Green; -65432" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")