import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(Leader|Head\\\\Organiser|Head|Head\\\\Secretary|Captain|Vice Captain)[ \\t:-]+(.*?)[ \\t]*[;#]+";
final String string = "Leader : Tim Lee ; 34567\n"
+ "Head\\Organiser: Sam Mathews; 11:53 am\n"
+ "Head: Alica Mills; 45612\n"
+ "Head\\Secretary: Maya Hill; #53190\n"
+ "Captain- Jocey David # 45123\n"
+ "Vice Captain:- Jacob Green; -65432\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}