$re = '/^\s*(Leader|Head\\\\Organiser|Head|Head\\\\Secretary|Captain|Vice Captain)[ \t:-]+(.*?)[ \t]*[;#]+/m';
$str = 'Leader : Tim Lee ; 34567
Head\\Organiser: Sam Mathews; 11:53 am
Head: Alica Mills; 45612
Head\\Secretary: Maya Hill; #53190
Captain- Jocey David # 45123
Vice Captain:- Jacob Green; -65432
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);